Skip to main content
Version: 3.3.1

SDK Deprecation Policy

Overview

When we release new versions of the Appodeal SDK, we will phase out older versions. Once a version is phased out, it may no longer fill or display ads, resulting in no ad traffic.

What SDKs Are Deprecated?

Starting May 31, 2024, we will no longer support older versions of the Appodeal SDK, along with all related modules and plugins. These versions will not receive any updates, including important security patches or fixes for newer OS versions.

Why The Deprecation?

Using the latest Appodeal SDK version and introducing a predictable deprecation schedule offers several benefits:

  1. Improved Security: The latest Appodeal SDK includes vital security updates that protect developers and users from potential vulnerabilities.
  2. Improved Performance: Expect faster load times and smoother ad displays with significant performance enhancements in the new SDK versions.
  3. New Features: Enhance your monetization strategies with advanced analytics, new ad formats, and improved mediation capabilities.
  4. Compliance: Stay up-to-date with the latest laws, such as GDPR and CCPA.
  5. Predictable Updates: Offers developers a clear timeframe for planning and implementing SDK updates.
  6. Efficiency: Reduces SDK size and bug risks by removing legacy code.
  7. Innovation Focus: Allocates engineering resources to support and enhance newer SDKs.

What Do You Need To Do?

To ensure a seamless transition, we recommend that developers upgrade to the latest version of the Appodeal SDK as soon as possible. Follow these steps to update your SDK:

  1. Backup Your Project: This will prevent any data loss.
  2. Update Dependencies: Modify your project's dependency settings to include the latest Appodeal SDK.
  3. Test Your Application: Ensure all features work as expected with the new SDK version.

Timetable

VersionStatusRelease DateDeprecation DateSunset DateMigration Guide
3.3.xSupportedApril 30, 2024
3.2.xSupportedMarch 29, 2023Q3 2024Q1 2025Migrate to 3.3.x
3.1.xDeprecatedSeptember 4, 2023May 31, 2024Q4 2024Migrate to 3.2.x
3.0.xDeprecatedMay 23, 2022May 31, 2024June 30, 2024Migrate to 3.1.x
2.11.xDeprecatedDecember 28, 2021May 31, 2024June 30, 2024Migrate to 3.0.x
2.10.xDeprecatedMay 4, 2021May 31, 2024June 30, 2024Migrate to 2.11.x
2.9.xDeprecatedFebruary 8, 2021May 31, 2024June 30, 2024Migrate to 2.10.x
Support for SDK versions 2.8.x and below has been discontinued.

What Are The Differences Between Supported, Deprecated, And Sunset Versions?

TermSupportedDeprecatedSunset
SDK VersionsMinor release N and N-1Minor release N-2Minor release N-3 or below
Ad ServingAds serve to this versionAds serve to this versionAds risk no-fill, potential disablement
SupportFull technical supportLimited support; validate in supported versionNo support; validate in supported version
UpdatesReceives new features, security patches, and bug fixesNo updates providedNo updates provided
DocumentationFull documentation availableLimited documentation availableDocumentation not updated or maintained
CompatibilityFully compatible with latest OS versionsPotentially incompatible with new OS versionsPotentially incompatible with new OS versions
Bug FixesRegular bug fixes and patchesNo bug fixes providedNo bug fixes provided

Exceptions

While this schedule provides predictable SDK lifetimes, exceptions may occur, including earlier sunset dates. We commit to proactive communication with ample lead time for any changes.

How To Get Support And Contact Information

  • Ticket: Click on the chat bubble in the bottom right corner of the screen and create a ticket by choosing the required category of the request. You need to be logged in to your Appodeal account.
  • Email: [email protected]